eRA Browser Compatibility

Updated eRA is committed to delivering secure web modules that are compliant with web standards, and we aim for cross-browser compatibility. To ensure this, our development teams must use the capabilities and improved security and performance provided by the most up to date browsers, since older versions are typically no longer supported by their development company and therefore vulnerable.

We strive to verify our web modules work properly and efficiently with a reasonable range of browsers.

The following information will help ensure you have the best experience when using eRA modules such as eRA Commons, ASSIST and Internet Assisted Review (IAR).

Currently, our modules are developed and tested for compatibility using the following browser versions:

  • Internet Explorer 11.x
  • Mozilla Firefox 42.x
  • Google Chrome 46.x

Resolving Browser Issues
If you are experiencing a problem using one of the browsers mentioned above, please contact the eRA Service Desk for assistance.